You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/gnome-extra/gnome-search-tool/gnome-search-tool-3.6.0.ebuild

43 lines
862 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
inherit gnome2
DESCRIPTION="Search tool for GNOME 3"
HOMEPAGE="https://wiki.gnome.org/Apps/Attic/GnomeUtils"
LICENSE="GPL-2 FDL-1.1"
SLOT="0"
IUSE=""
KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
COMMON_DEPEND="
dev-libs/atk
>=dev-libs/glib-2.30:2
sys-apps/grep
x11-libs/gdk-pixbuf
>=x11-libs/gtk+-3:3[X]
x11-libs/libICE
x11-libs/libSM
"
RDEPEND="${COMMON_DEPEND}
sys-apps/findutils
sys-apps/mlocate
!<gnome-extra/gnome-utils-3.4
"
# ${PN} was part of gnome-utils before 3.4
DEPEND="${COMMON_DEPEND}
>=dev-util/intltool-0.40
>=sys-devel/gettext-0.17
virtual/pkgconfig
"
src_configure() {
G2CONF="${G2CONF} ITSTOOL=$(type -P true)"
gnome2_src_configure
}