You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/gui-apps/kanshi/kanshi-9999.ebuild

44 lines
817 B

# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit meson
DESCRIPTION="dynamic display configuration (autorandr for wayland)"
HOMEPAGE="https://github.com/emersion/kanshi"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/emersion/kanshi"
else
SRC_URI="https://github.com/emersion/kanshi/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~x86"
fi
LICENSE="MIT"
SLOT="0"
IUSE="+man"
RDEPEND="
dev-libs/wayland
"
BDEPEND="
${RDEPEND}
virtual/pkgconfig
dev-libs/wayland-protocols
"
if [[ ${PV} == 9999 ]]; then
BDEPEND+="man? ( ~app-text/scdoc-9999 )"
else
BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
fi
src_configure() {
local emesonargs=(
$(meson_feature man man-pages)
)
meson_src_configure
}