You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/gui-libs/libhandy/libhandy-0.0.13.ebuild

67 lines
1.6 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit meson xdg vala virtualx
MY_P="${PN}-v${PV}"
DESCRIPTION="Library with GTK widgets for mobile phones"
HOMEPAGE="https://source.puri.sm/Librem5/libhandy/"
SRC_URI="https://source.puri.sm/Librem5/libhandy/-/archive/v${PV}/${MY_P}.tar.bz2"
S="${WORKDIR}/${MY_P}"
LICENSE="LGPL-2.1+"
SLOT="0.0/0" # It may or may not break ABI in future versions at this point; if new
# SLOT happens, it'll likely file conflict on gtk-doc and glade library and catalog
KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~ppc ~ppc64 ~sparc x86"
IUSE="examples glade gtk-doc +introspection test +vala"
REQUIRED_USE="vala? ( introspection )"
RESTRICT="!test? ( test )"
RDEPEND="
>=dev-libs/glib-2.44:2
>=x11-libs/gtk+-3.24.1:3[introspection?]
glade? ( dev-util/glade:3.10= )
introspection? ( >=dev-libs/gobject-introspection-1.54:= )
"
DEPEND="${RDEPEND}"
BDEPEND="
vala? ( $(vala_depend) )
dev-libs/libxml2:2
dev-util/glib-utils
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
gtk-doc? ( dev-util/gtk-doc
app-text/docbook-xml-dtd:4.3 )
"
PATCHES=(
"${FILESDIR}"/${PV}-glade3.36-compat{1,2}.patch
"${FILESDIR}"/${PV}-glade3.37-compat.patch
)
src_prepare() {
use vala && vala_src_prepare
xdg_src_prepare
}
src_configure() {
local emesonargs=(
-Dprofiling=false # -pg passing
-Dstatic=false
$(meson_feature introspection)
$(meson_use vala vapi)
$(meson_use gtk-doc gtk_doc)
$(meson_use test tests)
$(meson_use examples)
$(meson_feature glade glade_catalog)
)
meson_src_configure
}
src_test() {
virtx meson_src_test
}