You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-frameworks/breeze-icons/breeze-icons-5.81.0.ebuild

42 lines
717 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PVCUT=$(ver_cut 1-2)
inherit cmake kde.org xdg-utils
DESCRIPTION="Breeze SVG icon theme"
LICENSE="LGPL-3"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
IUSE="test"
RESTRICT+=" !test? ( test )"
BDEPEND="
dev-qt/qtcore:5
>=kde-frameworks/extra-cmake-modules-${PVCUT}:5
test? ( app-misc/fdupes )
"
DEPEND="test? ( dev-qt/qttest:5 )"
src_prepare() {
cmake_src_prepare
use test || cmake_comment_add_subdirectory autotests
}
src_configure() {
local mycmakeargs=(
-DBINARY_ICONS_RESOURCE=OFF
)
cmake_src_configure
}
pkg_postinst() {
xdg_icon_cache_update
}
pkg_postrm() {
xdg_icon_cache_update
}