You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-frameworks/kcontacts/kcontacts-5.81.0.ebuild

36 lines
748 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
ECM_TEST="true"
PVCUT=$(ver_cut 1-2)
QTMIN=5.15.2
VIRTUALX_REQUIRED="test"
inherit ecm kde.org
DESCRIPTION="Address book API based on KDE Frameworks"
LICENSE="GPL-2+"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
IUSE=""
DEPEND="
>=dev-qt/qtgui-${QTMIN}:5
=kde-frameworks/kcodecs-${PVCUT}*:5
=kde-frameworks/kconfig-${PVCUT}*:5
=kde-frameworks/kcoreaddons-${PVCUT}*:5
=kde-frameworks/ki18n-${PVCUT}*:5
"
RDEPEND="${DEPEND}
!kde-apps/kcontacts:5
app-text/iso-codes
"
src_test() {
# bug #566648 (access to /dev/dri/card0 denied), bug #625988
local myctestargs=(
-E "(kcontacts-addresstest|kcontacts-picturetest)"
)
ecm_src_test
}