You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-frameworks/kcrash/kcrash-5.80.0.ebuild

33 lines
703 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PVCUT=$(ver_cut 1-2)
QTMIN=5.15.2
VIRTUALX_REQUIRED="test"
inherit ecm kde.org
DESCRIPTION="Framework for intercepting and handling application crashes"
LICENSE="LGPL-2+"
KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
IUSE="nls"
# requires running kde environment
RESTRICT+=" test"
BDEPEND="
nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
"
RDEPEND="
>=dev-qt/qtgui-${QTMIN}:5
>=dev-qt/qtx11extras-${QTMIN}:5
=kde-frameworks/kcoreaddons-${PVCUT}*:5
=kde-frameworks/kwindowsystem-${PVCUT}*:5
x11-libs/libX11
"
DEPEND="${RDEPEND}
x11-base/xorg-proto
test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
"