You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-frameworks/kwayland/kwayland-5.81.0.ebuild

35 lines
767 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
ECM_TEST="true"
PVCUT=$(ver_cut 1-2)
QTMIN=5.15.2
inherit ecm kde.org
DESCRIPTION="Qt-style client and server library wrapper for Wayland libraries"
HOMEPAGE="https://invent.kde.org/frameworks/kwayland"
LICENSE="LGPL-2.1"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
IUSE=""
# All failing, I guess we need a virtual wayland server
RESTRICT+=" test"
RDEPEND="
>=dev-libs/wayland-1.15.0
>=dev-qt/qtconcurrent-${QTMIN}:5
>=dev-qt/qtgui-${QTMIN}:5[egl]
>=dev-qt/qtwayland-${QTMIN}:5
media-libs/mesa[egl]
"
DEPEND="${RDEPEND}
>=dev-libs/plasma-wayland-protocols-1.2.1
>=dev-libs/wayland-protocols-1.15
"
BDEPEND="
>=dev-util/wayland-scanner-1.19.0
"