You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-misc/plasma-pass/plasma-pass-1.2.0.ebuild

40 lines
982 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
KFMIN=5.74.0
QTMIN=5.15.2
inherit ecm kde.org
DESCRIPTION="Plasma applet to access password from pass"
HOMEPAGE="https://www.dvratil.cz/2018/05/plasma-pass/ https://invent.kde.org/plasma/plasma-pass"
if [[ ${KDE_BUILD_TYPE} != live ]] ; then
SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
KEYWORDS="amd64 ~ppc64"
fi
LICENSE="LGPL-2.1+"
SLOT="5"
IUSE=""
DEPEND="
>=dev-qt/qtconcurrent-${QTMIN}:5
>=dev-qt/qtdbus-${QTMIN}:5
>=dev-qt/qtdeclarative-${QTMIN}:5
>=dev-qt/qtgraphicaleffects-${QTMIN}:5
>=dev-qt/qtgui-${QTMIN}:5
>=kde-frameworks/kcoreaddons-${KFMIN}:5
>=kde-frameworks/ki18n-${KFMIN}:5
>=kde-frameworks/kitemmodels-${KFMIN}:5
>=kde-frameworks/plasma-${KFMIN}:5
sys-auth/oath-toolkit
"
RDEPEND="${DEPEND}
>=dev-qt/qtquickcontrols2-${QTMIN}:5
>=kde-frameworks/kirigami-${KFMIN}:5
"
PATCHES=( "${FILESDIR}"/${P}-no-werror.patch ) # bug 785832