You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-plasma/kwallet-pam/kwallet-pam-5.20.5-r1.ebuild

40 lines
805 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
KFMIN=5.74.0
PVCUT=$(ver_cut 1-3)
inherit ecm kde.org
DESCRIPTION="PAM module to not enter KWallet password again after login"
LICENSE="LGPL-2.1"
SLOT="5"
KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
IUSE=""
DEPEND="
dev-libs/libgcrypt:0=
>=kde-frameworks/kwallet-${KFMIN}:5
sys-libs/pam
"
RDEPEND="${DEPEND}
net-misc/socat
"
PATCHES=( "${FILESDIR}/${P}-socket-listening-error.patch" ) # bug 717606
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
)
ecm_src_configure
}
pkg_postinst() {
ecm_pkg_postinst
elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
}