You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/lxqt-base/lxqt-config/lxqt-config-0.17.1.ebuild

73 lines
1.4 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cmake xdg-utils
DESCRIPTION="LXQt system configuration control center"
HOMEPAGE="https://lxqt.github.io/"
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
fi
LICENSE="GPL-2 GPL-2+ GPL-3 LGPL-2 LGPL-2+ LGPL-2.1+ WTFPL-2"
SLOT="0"
IUSE="+monitor +touchpad"
BDEPEND="
dev-qt/linguist-tools:5
>=dev-util/lxqt-build-tools-0.9.0
"
DEPEND="
>=dev-libs/libqtxdg-3.3.1
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
dev-qt/qtxml:5
kde-frameworks/kwindowsystem:5
=lxqt-base/liblxqt-$(ver_cut 1-2)*
sys-libs/zlib:=
x11-apps/setxkbmap
x11-libs/libxcb:=
x11-libs/libX11
x11-libs/libXcursor
x11-libs/libXfixes
monitor? ( kde-plasma/libkscreen:5= )
touchpad? (
virtual/libudev
x11-drivers/xf86-input-libinput
x11-libs/libXext
x11-libs/libXi
)
"
RDEPEND="${DEPEND}"
src_configure() {
local mycmakeargs=(
-DWITH_MONITOR=$(usex monitor)
-DWITH_TOUCHPAD=$(usex touchpad)
)
cmake_src_configure
}
src_install() {
cmake_src_install
doman man/*.1 liblxqt-config-cursor/man/*.1 lxqt-config-appearance/man/*.1
}
pkg_postinst() {
xdg_icon_cache_update
}
pkg_postrm() {
xdg_icon_cache_update
}