You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-fonts/noto/noto-20200521.ebuild

47 lines
1.4 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit font
DESCRIPTION="Google's font family that aims to support all the world's languages"
HOMEPAGE="https://www.google.com/get/noto/ https://github.com/googlei18n/noto-fonts"
COMMIT="49313785484cd4d1f4c0329ee3a8801f158f5ba1"
SRC_URI="https://github.com/googlei18n/noto-fonts/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
LICENSE="OFL-1.1"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~mips ppc ppc64 sparc x86"
# Extra allows to optionally reduce disk usage even returning to tofu
# issue as described in https://www.google.com/get/noto/
IUSE="cjk +extra"
RDEPEND="cjk? ( media-fonts/noto-cjk )"
DEPEND=""
RESTRICT="binchecks strip"
S="${WORKDIR}/${PN}-fonts-${COMMIT}"
FONT_SUFFIX="ttf"
FONT_CONF=(
# From ArchLinux
"${FILESDIR}/66-noto-serif.conf"
"${FILESDIR}/66-noto-mono.conf"
"${FILESDIR}/66-noto-sans.conf"
)
src_install() {
mkdir install-unhinted install-hinted || die
mv unhinted/*/* install-unhinted/. || die
mv hinted/*/* install-hinted/. || die
FONT_S="${S}/install-unhinted/" font_src_install
FONT_S="${S}/install-hinted/" font_src_install
# Allow to drop some fonts optionally for people that want to save
# disk space. Following ArchLinux options.
use extra || rm -rf "${ED}"/usr/share/fonts/noto/Noto*{Condensed,SemiBold,Extra}*.ttf
}