You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-gfx/chafa/chafa-1.6.0.ebuild

37 lines
764 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="versatile and fast Unicode/ASCII/ANSI graphics renderer"
HOMEPAGE="https://hpjansson.org/chafa/ https://github.com/hpjansson/chafa"
SRC_URI="https://hpjansson.org/chafa/releases/${P}.tar.xz"
LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="amd64 arm64 x86"
IUSE="+tools"
RDEPEND="
dev-libs/glib:2
media-gfx/imagemagick:0=
tools? ( >=media-libs/freetype-2.0.0 )"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
src_configure() {
econf \
--disable-static \
--disable-man \
$(use_with tools)
}
src_install() {
local DOCS=( AUTHORS NEWS README TODO )
default
use tools && doman docs/chafa.1
find "${ED}" -name '*.la' -delete || die
}