You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-gfx/gif2apng/gif2apng-1.9-r1.ebuild

39 lines
640 B

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
DESCRIPTION="create an APNG from a GIF"
HOMEPAGE="https://sourceforge.net/projects/gif2apng/"
SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
LICENSE="ZLIB LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="sys-libs/zlib
app-arch/zopfli:="
DEPEND="${RDEPEND}
app-arch/unzip"
S=${WORKDIR}
PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
src_prepare() {
default
# remove bundled libs
rm -r zlib zopfli || die
tc-export CC
}
src_install() {
dobin ${PN}
dodoc readme.txt
}