You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-gfx/monica/monica-3.7.ebuild

39 lines
718 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
DESCRIPTION="Monica is a Monitor Calibration Tool"
HOMEPAGE="http://freshmeat.sourceforge.net/projects/monica"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
DEPEND=">=x11-libs/fltk-1.1:1"
RDEPEND="${DEPEND}
x11-apps/xgamma"
DOCS=( authors ChangeLog news readme )
PATCHES=(
"${FILESDIR}"/${PN}-3.6-makefile-cleanup.patch
"${FILESDIR}"/${P}-gcc44.patch
)
src_compile() {
emake \
CXX="$(tc-getCXX)" \
CXXFLAGS="${CXXFLAGS}" \
LINK="$(tc-getCXX)" \
LDFLAGS="${LDFLAGS}"
}
src_install() {
dobin monica
einstalldocs
}