You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/codec2/codec2-0.9.2-r1.ebuild

27 lines
671 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="Low bit rate speech codec"
HOMEPAGE="https://freedv.org/ http://www.rowetel.com/?page_id=452"
SRC_URI="https://github.com/drowe67/codec2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0/0.9"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86"
IUSE="examples test"
# Not yet passing, but infrastructure added to run
RESTRICT="test"
multilib_src_configure() {
local mycmakeargs=(
-DUNITTEST=$(usex test)
-DINSTALL_EXAMPLES=$(usex examples)
)
cmake_src_configure
}