You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/lib3ds/lib3ds-2.0.0_rc1-r1.ebuild

36 lines
700 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
MY_PV="20080909"
MY_P="${PN}-${MY_PV}"
DESCRIPTION="library for managing 3D-Studio Release 3 and 4 .3DS files"
HOMEPAGE="https://code.google.com/p/lib3ds/"
SRC_URI="https://lib3ds.googlecode.com/files/${MY_P}.zip"
LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 x86"
IUSE="static-libs"
BDEPEND="app-arch/unzip"
S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${P}-underlinking-no-autoreconf.patch
)
src_configure() {
econf $(use_enable static-libs static)
}
src_install() {
default
if ! use static-libs; then
find "${ED}" -name '*.la' -delete || die
fi
}