You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/libfreehand/libfreehand-0.1.2.ebuild

60 lines
1.2 KiB

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit flag-o-matic
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libfreehand.git"
[[ ${PV} == 9999 ]] && inherit autotools git-r3
DESCRIPTION="Library for import of FreeHand drawings"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libfreehand"
[[ ${PV} == 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/libfreehand/${P}.tar.xz"
LICENSE="MPL-2.0"
SLOT="0"
[[ ${PV} == 9999 ]] || \
KEYWORDS="amd64 ~arm arm64 ~hppa ppc ppc64 ~sparc x86"
IUSE="doc static-libs test"
RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/librevenge
sys-libs/zlib
"
DEPEND="${RDEPEND}
dev-libs/boost
dev-libs/icu
dev-util/gperf
media-libs/lcms
sys-devel/libtool
virtual/pkgconfig
doc? ( app-doc/doxygen )
test? ( dev-util/cppunit )
"
PATCHES=( "${FILESDIR}/${P}-icu-65.patch" )
src_prepare() {
default
[[ -d m4 ]] || mkdir "m4"
[[ ${PV} == 9999 ]] && eautoreconf
}
src_configure() {
# bug 619762
append-cxxflags -std=c++14
econf \
--disable-werror \
$(use_with doc docs) \
$(use_enable static-libs static) \
$(use_enable test tests)
}
src_install() {
default
find "${D}" -name '*.la' -delete || die
}