You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/liblscp/liblscp-0.6.2.ebuild

29 lines
637 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="C++ library for the Linux Sampler control protocol"
HOMEPAGE="https://www.linuxsampler.org"
SRC_URI="https://www.rncbc.org/archive/${P}.tar.gz
https://download.linuxsampler.org/packages/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="doc"
BDEPEND="doc? ( app-doc/doxygen )"
DOCS=( AUTHORS ChangeLog TODO NEWS README )
src_configure() {
econf --disable-static
}
src_install() {
use doc && local HTML_DOCS=( doc/html/. )
default
find "${D}" -name '*.la' -type f -delete || die
}