You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/liblscp/liblscp-9999.ebuild

37 lines
666 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools subversion
DESCRIPTION="C++ library for the Linux Sampler control protocol"
HOMEPAGE="https://www.linuxsampler.org"
ESVN_REPO_URI="https://svn.linuxsampler.org/svn/liblscp/trunk"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS=""
IUSE="doc"
BDEPEND="doc? ( app-doc/doxygen )"
DOCS=( AUTHORS ChangeLog TODO NEWS README )
src_prepare() {
default
emake -f Makefile.git
eautoreconf
}
src_configure() {
econf --disable-static
}
src_install() {
use doc && local HTML_DOCS=( doc/html/. )
default
find "${D}" -name '*.la' -delete || die
}