You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/libmng/libmng-2.0.3.ebuild

48 lines
1.2 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools multilib-minimal
DESCRIPTION="Multiple Image Networkgraphics lib (animated png's)"
HOMEPAGE="https://www.libmng.com/"
SRC_URI="mirror://sourceforge/libmng/${P}.tar.xz"
LICENSE="libmng"
SLOT="0/2"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="lcms static-libs"
RDEPEND="
>=sys-libs/zlib-1.2.8-r1[static-libs?,${MULTILIB_USEDEP}]
>=virtual/jpeg-0-r2:0[static-libs?,${MULTILIB_USEDEP}]
lcms? ( >=media-libs/lcms-2.5:2[static-libs?,${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}"/${P}-jpeg-9a.patch )
src_prepare() {
default
# effect of 'make distclean'
rm Makefile config.h config.log config.status libmng.pc stamp-h1 || die
eautoreconf
}
multilib_src_configure() {
local myeconfargs=(
$(use_enable static-libs static)
--with-jpeg
$(use_with lcms lcms2)
--without-lcms
)
ECONF_SOURCE="${S}" \
econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
dodoc CHANGES README* doc/{doc.readme,libmng.txt}
doman doc/man/*.{3,5}
}