You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/libnsgif/libnsgif-0.2.1-r3.ebuild

40 lines
806 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit netsurf
DESCRIPTION="decoding library for the GIF image file format, written in C"
HOMEPAGE="https://www.netsurf-browser.org/projects/libnsgif/"
SRC_URI="https://download.netsurf-browser.org/libs/releases/${P}-src.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~ppc ppc64 x86"
IUSE=""
BDEPEND="
>=dev-util/netsurf-buildsystem-1.7-r1
virtual/pkgconfig
"
src_prepare() {
default
sed -e '1i#pragma GCC diagnostic ignored "-Wimplicit-fallthrough"' \
-i src/lzw.c || die
}
_emake() {
netsurf_define_makeconf
emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared $@
}
src_compile() {
_emake
}
src_install() {
_emake DESTDIR="${D}" install
}