You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/libtimidity/libtimidity-0.2.6.ebuild

38 lines
818 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit multilib-minimal
DESCRIPTION="MIDI to WAVE converter library"
HOMEPAGE="http://libtimidity.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0/2"
KEYWORDS="amd64 ~arm64 ~hppa ppc ppc64 sparc x86"
IUSE="ao debug"
RESTRICT="test"
RDEPEND="ao? ( >=media-libs/libao-1.1.0-r2[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
DOCS=( AUTHORS CHANGES TODO README README.timidity )
multilib_src_configure() {
local myeconfargs=(
--disable-static
$(use_enable ao)
$(use_enable debug)
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
einstalldocs
find "${D}" -name '*.la' -type f -delete || die
}