You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/mutagen/mutagen-1.45.1.ebuild

48 lines
1.1 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
DESCRIPTION="Audio metadata tag reader and writer implemented in pure Python"
HOMEPAGE="https://github.com/quodlibet/mutagen https://pypi.org/project/mutagen/"
SRC_URI="https://github.com/quodlibet/mutagen/releases/download/release-${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
# TODO: Missing support for >=dev-python/eyeD3-0.7 API
# test? ( >=dev-python/eyeD3-0.7 )
BDEPEND="
doc? (
dev-python/sphinx
dev-python/sphinx_rtd_theme
)
test? (
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/pyflakes[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
)
"
RESTRICT="!test? ( test )"
python_compile_all() {
use doc && emake -C docs
}
python_test() {
esetup.py test --no-quality
}
python_install_all() {
local DOCS=( NEWS README.rst )
use doc && local HTML_DOCS=( docs/_build/. )
distutils-r1_python_install_all
}