You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/openexr_ctl/openexr_ctl-1.0.1-r2.ebuild

41 lines
857 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit autotools epatch ltprune
DESCRIPTION="OpenEXR CTL libraries"
HOMEPAGE="https://sourceforge.net/projects/ampasctl"
SRC_URI="mirror://sourceforge/ampasctl/${P}.tar.gz"
LICENSE="AMPAS"
SLOT="0"
KEYWORDS="amd64 ~hppa ~ia64 ppc ppc64 sparc x86"
IUSE="static-libs"
RDEPEND=">=media-libs/ilmbase-2.0.1:=
>=media-libs/openexr-2.0.1:=
media-libs/ctl:="
DEPEND="${RDEPEND}
virtual/pkgconfig"
DOCS="AUTHORS ChangeLog NEWS README"
src_prepare() {
epatch \
"${FILESDIR}"/${P}-{,configure_}gcc43.patch \
"${FILESDIR}"/${P}-pkgconfig.patch \
"${FILESDIR}"/${P}-gcc44.patch \
"${FILESDIR}"/${P}-namespace.patch
eautoreconf
}
src_configure() {
econf $(use_enable static-libs static)
}
src_install() {
default
prune_libtool_files
}