You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/vidstab/vidstab-9999.ebuild

56 lines
1.5 KiB

# Copyright 2018-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_ECLASS=cmake
inherit cmake-multilib toolchain-funcs
DESCRIPTION="Video stabilization library"
HOMEPAGE="http://public.hronopik.de/vid.stab/"
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/georgmartius/vid.stab.git"
inherit git-r3
else
SRC_URI="https://github.com/georgmartius/vid.stab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~ppc ~ppc64 ~sparc x86"
S="${WORKDIR}/vid.stab-${PV}"
fi
LICENSE="GPL-2+"
SLOT="0"
IUSE="openmp cpu_flags_x86_sse2"
src_prepare() {
# USE=cpu_flags_x86_sse2 instead
sed -E 's#include (FindSSE)##' -i CMakeLists.txt || die
sed -E 's#include (FindSSE)##' -i tests/CMakeLists.txt || die
# strip some CFLAGS
for FILE_TO_PATCH in {,transcode/,tests/}CMakeLists.txt; do
sed -E 's#(add_definitions.* )-g #\1#' -i ${FILE_TO_PATCH} || die
sed -E 's#(add_definitions.* )-O3 #\1#' -i ${FILE_TO_PATCH} || die
done
cmake_src_prepare
}
src_configure() {
use openmp && tc-check-openmp
local mycmakeargs=(
-DUSE_OMP="$(usex openmp)"
-DSSE2_FOUND="$(usex cpu_flags_x86_sse2)"
)
cmake-multilib_src_configure
}
multilib_src_test() {
local mycmakeargs=(
-DUSE_OMP="$(usex openmp)"
-DSSE2_FOUND="$(usex cpu_flags_x86_sse2)"
)
local CMAKE_USE_DIR="${CMAKE_USE_DIR}/tests"
local BUILD_DIR="${BUILD_DIR}/tests"
cmake_src_configure
cmake_build
"${BUILD_DIR}"/tests || die
}