You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-radio/grig/grig-0.8.1.ebuild

32 lines
653 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit eutils
DESCRIPTION="A tool for controlling amateur radios"
HOMEPAGE="http://groundstation.sourceforge.net/grig/"
SRC_URI="mirror://sourceforge/groundstation/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
DEPEND="
dev-libs/glib:2
x11-libs/gtk+:2
<media-libs/hamlib-3.4"
RDEPEND="${DEPEND}"
src_configure() {
econf --enable-hardware
}
src_install() {
default
make_desktop_entry ${PN} "GRig" "/usr/share/pixmaps/grig/grig-logo.png" "HamRadio"
rm -rf "${D}/usr/share/grig" || die "cleanup docs failed"
}