You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-radio/ibp/ibp-0.21-r1.ebuild

54 lines
1.1 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
inherit toolchain-funcs
DESCRIPTION="Shows currently transmitting beacons of the International Beacon Project (IBP)"
HOMEPAGE="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/ibp.html"
SRC_URI="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="X"
RDEPEND="sys-libs/ncurses:0
X? ( x11-libs/libX11 )"
DEPEND="${RDEPEND}
X? ( >=x11-misc/imake-1.0.8-r1 )"
src_prepare() {
# respect CFLAGS if built without USE=X
sed -i -e "s/= -D/+= -D/" Makefile || die
# fix compile if ncurses is built with separate libtinfo
if has_version "sys-libs/ncurses:0[tinfo]" ;then
sed -i -e "s/-lcurses/-lcurses -ltinfo/" Imakefile Makefile || die
fi
eapply_user
}
src_configure() {
if use X ;then
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
fi
}
src_compile() {
if use X ; then
emake \
CC="$(tc-getCC)" \
LOCAL_LDFLAGS="${LDFLAGS}" \
CDEBUGFLAGS="${CFLAGS}"
else
emake CC="$(tc-getCC)"
fi
}
src_install() {
dobin ${PN}
doman ${PN}.1
}