You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/fapg/fapg-0.43.ebuild

28 lines
553 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Fast Audio Playlist Generator"
HOMEPAGE="http://royale.zerezo.com/fapg/"
SRC_URI="http://royale.zerezo.com/fapg/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 x86"
IUSE="xspf"
DEPEND="xspf? ( >=dev-libs/uriparser-0.6.3 )"
RDEPEND="${DEPEND}"
src_configure() {
local myconf=""
use xspf || myconf="${myconf} --disable-xspf"
econf ${myconf}
}
src_install() {
emake DESTDIR="${D}" install
einstalldocs
}