You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/gtkguitune/gtkguitune-0.8.ebuild

36 lines
705 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit desktop xdg
DESCRIPTION="A guitar tuning program that uses Schmitt-triggering for quick feedback"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="mirror://gentoo/${PN}-gtk2-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
RDEPEND="
dev-cpp/glibmm:2
dev-cpp/gtkmm:2.4
dev-libs/libsigc++:2"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/${PN}"
src_configure() {
# improperly packaged tarball, contains object code
emake distclean
default
}
src_install() {
default
make_desktop_entry gtkguitune Guitune guitune_logo
}