You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/madplay/madplay-0.15.2b-r1.ebuild

40 lines
768 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools
DESCRIPTION="The MAD audio player"
HOMEPAGE="http://www.underbit.com/products/mad/"
SRC_URI="mirror://sourceforge/mad/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="alsa nls"
RDEPEND="
media-libs/libid3tag:=
media-libs/libmad:=
alsa? ( media-libs/alsa-lib:= )"
DEPEND="${RDEPEND}"
BDEPEND="nls? ( sys-devel/gettext )"
PATCHES=(
"${FILESDIR}"/${PN}-macos.patch
"${FILESDIR}"/${P}-fix-autoconf.patch
)
src_prepare() {
default
eautoreconf
}
src_configure() {
econf \
$(use_enable nls) \
$(use_with alsa) \
--without-esd
}