You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/paprefs/paprefs-1.1-r1.ebuild

47 lines
939 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit flag-o-matic meson xdg-utils
DESCRIPTION="PulseAudio Preferences, configuration dialog for PulseAudio"
HOMEPAGE="https://freedesktop.org/software/pulseaudio/paprefs"
SRC_URI="https://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ~ppc ~sparc x86"
RDEPEND="dev-cpp/atkmm:0
dev-cpp/glibmm:2
dev-cpp/gtkmm:3.0
dev-libs/glib:2
>=dev-libs/libsigc++-2.2:2
>=media-sound/pulseaudio-12.0-r1[glib]
x11-libs/gtk+:3
|| (
x11-themes/tango-icon-theme
x11-themes/adwaita-icon-theme
)"
DEPEND="${RDEPEND}"
BDEPEND="
sys-devel/gettext
virtual/pkgconfig
"
src_configure() {
append-cxxflags -std=c++11 #568590
local mymesonargs=(
-Dlynx=false
)
meson_src_configure
}
pkg_postinst() {
xdg_desktop_database_update
}
pkg_postrm() {
xdg_desktop_database_update
}