You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/pavucontrol-qt/pavucontrol-qt-0.17.0.ebuild

34 lines
666 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cmake
DESCRIPTION="Qt GUI Pulseaudio Mixer"
HOMEPAGE="https://lxqt.github.io/"
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
fi
LICENSE="GPL-2 GPL-2+"
SLOT="0"
BDEPEND="
dev-qt/linguist-tools:5
>=dev-util/lxqt-build-tools-0.9.0
virtual/pkgconfig
"
DEPEND="
dev-libs/glib:2
dev-qt/qtcore:5
dev-qt/qtwidgets:5
media-sound/pulseaudio[glib]
"
RDEPEND="${DEPEND}"