You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/scmpc/scmpc-0.4.1.ebuild

34 lines
689 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="a client for MPD which submits your tracks to last.fm"
HOMEPAGE="https://cmende.github.com/scmpc/"
SRC_URI="https://dev.gentoo.org/~angelos/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
RDEPEND="
dev-libs/glib:2
dev-libs/confuse:=
media-libs/libmpdclient:=
net-misc/curl:="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${PN}-0.4.1-fno-common.patch
)
src_install() {
default
dodoc scmpc.conf.example
newinitd "${FILESDIR}"/${PN}-2.init ${PN}
insinto /etc
insopts -m600
newins scmpc.conf.example scmpc.conf
}