You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/umix/umix-1.0.2-r1.ebuild

35 lines
696 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools
DESCRIPTION="Program for adjusting soundcard volumes"
HOMEPAGE="http://umix.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~alpha amd64 ppc sparc x86"
IUSE="ncurses oss"
DEPEND="ncurses? ( >=sys-libs/ncurses-5.2:= )"
RDEPEND="${DEPEND}"
DOCS=( AUTHORS ChangeLog NEWS README TODO )
PATCHES=( "${FILESDIR}"/${P}-tinfo.patch )
src_prepare() {
default
eautoreconf
}
src_configure() {
local myconf
use ncurses || myconf="--disable-ncurses"
use oss || myconf="${myconf} --disable-oss"
econf ${myconf}
}