You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-video/mkvalidator/mkvalidator-0.5.2.ebuild

39 lines
904 B

# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit toolchain-funcs
DESCRIPTION="mkvalidator is a command line tool to verify Matroska files for spec conformance"
HOMEPAGE="https://www.matroska.org/downloads/mkvalidator.html"
SRC_URI="https://downloads.sourceforge.net/project/matroska/${PN}/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
src_configure() {
tc-export CC CXX
emake -C corec/tools/coremake
mv corec/tools/coremake/coremake . || die
./coremake $(corec/tools/coremake/system_output.sh) || die
# fixing generated makefiles
sed -i -e 's|^\(LFLAGS.*+=.*\$(LIBS)\)|\1 \$(LDFLAGS)|g' \
-e 's|^\(STRIP.*=\)|\1 echo|g' $(find -name "*.mak") || die
}
src_compile() {
emake -j1 V=1 -C ${PN}
}
src_install() {
dobin release/*/mkv*
newdoc ChangeLog.txt ChangeLog
newdoc ReadMe.txt README
}