You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-video/movit/movit-1.6.2.ebuild

49 lines
906 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit eutils
# no sane way to use OpenGL from within tests?
RESTRICT="test"
DESCRIPTION="Modern Video Toolkit"
HOMEPAGE="https://movit.sesse.net/"
# Tests need gtest, makefile unconditionally builds tests, so ... yey!
SRC_URI="https://movit.sesse.net/${P}.tar.gz
https://googletest.googlecode.com/files/gtest-1.7.0.zip"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 arm64 ~ppc64 x86"
IUSE=""
RDEPEND="media-libs/mesa[X(+)]
>=dev-cpp/eigen-3.2.0:3
media-libs/libepoxy
>=sci-libs/fftw-3
media-libs/libsdl2
"
DEPEND="
${RDEPEND}
app-arch/unzip
"
src_configure() {
econf --disable-static
}
src_compile() {
GTEST_DIR="${WORKDIR}/gtest-1.7.0" emake
}
src_test() {
GTEST_DIR="${WORKDIR}/gtest-1.7.0" emake check
}
src_install() {
default
find "${ED}" -name '*.la' -delete || die
}