You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-video/subcheck/subcheck-0.78.2-r1.ebuild

32 lines
657 B

# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Subcheck checks srt subtitle files for errors"
HOMEPAGE="http://subcheck.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="!sci-biology/ncbi-tools++" # bug 377093
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}"
src_prepare() {
default
sed -i -e "s:${PN}.pl:${PN}:g" all-checksub || die "sed failed"
}
src_install() {
gunzip man/subcheck.8.gz || die
doman man/subcheck.8
newbin subcheck.pl subcheck
dobin all-checksub
dodoc Changes
}