You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/hexinject/hexinject-1.6-r1.ebuild

37 lines
697 B

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
inherit toolchain-funcs
DESCRIPTION="Network packet sniffer and injector"
HOMEPAGE="http://hexinject.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+tools experimental"
DEPEND="net-libs/libpcap"
RDEPEND="${DEPEND}
experimental? ( dev-lang/tcl )"
S="${WORKDIR}/${PN}"
PATCHES=( "${FILESDIR}"/${PN}-1.6-fix-build-system.patch )
src_configure() {
default
tc-export CC
}
src_install() {
dobin hexinject
use tools && dobin hex2raw prettypacket
use experimental && dobin packets.tcl
einstalldocs
}