You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/ospd/ospd-2.0.1.ebuild

35 lines
753 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
DESCRIPTION="Base class for scanner wrappers,communication protocol for GVM"
HOMEPAGE="https://www.greenbone.net/en/"
SRC_URI="https://github.com/greenbone/ospd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE="extras"
RDEPEND="
dev-python/defusedxml[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/paramiko[${PYTHON_USEDEP}]"
DEPEND="
${RDEPEND}"
distutils_enable_tests unittest
python_compile() {
if use extras; then
bash "${S}"/doc/generate || die
HTML_DOCS=( "${S}"/doc/. )
fi
distutils-r1_python_compile
}