You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/scapy/scapy-2.4.4-r1.ebuild

49 lines
1.1 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1 readme.gentoo-r1
DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
HOMEPAGE="https://scapy.net/ https://github.com/secdev/scapy"
SRC_URI="https://github.com/secdev/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
DOC_CONTENTS="
Scapy has optional support for the following packages:
dev-python/cryptography
dev-python/ipython
dev-python/matplotlib
dev-python/pyx
media-gfx/graphviz
net-analyzer/tcpdump
net-analyzer/tcpreplay
net-libs/libpcap
virtual/imagemagick-tools
See also ""${EPREFIX}/usr/share/doc/${PF}/installation.rst""
"
PATCHES=("${FILESDIR}/${P}-libc.patch")
src_prepare() {
if ! [[ -f ${PN}/VERSION ]]; then
echo ${PV} > ${PN}/VERSION || die
else
die
fi
distutils-r1_src_prepare
}
src_install() {
distutils-r1_src_install
dodoc -r doc/${PN}/*
DISABLE_AUTOFORMATTING=plz readme.gentoo_create_doc
}