You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/scli/scli-0.4.0-r1.ebuild

37 lines
650 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit autotools epatch
DESCRIPTION="SNMP Command Line Interface"
HOMEPAGE="https://github.com/schoenw/scli"
SRC_URI="ftp://ftp.ibr.cs.tu-bs.de/pub/local/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux"
RDEPEND="
dev-libs/glib:2
dev-libs/libxml2
net-libs/gnet
net-libs/gsnmp
sys-libs/ncurses
sys-libs/readline
sys-libs/zlib
"
DEPEND="
${RDEPEND}
virtual/pkgconfig
"
DOCS=( AUTHORS ChangeLog NEWS PORTING README TODO )
src_prepare() {
epatch "${FILESDIR}"/${P}-configure.patch
eautoreconf
}