You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/tcping/tcping-1.3.6.ebuild

29 lines
624 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="Check if a desired port is reachable via TCP"
HOMEPAGE="https://github.com/mkirchner/tcping"
SRC_URI="https://github.com/mkirchner/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT-with-advertising"
SLOT="0"
KEYWORDS="~amd64 ~x86"
src_prepare() {
default
sed -e '/^CC=/s:=:?=:' \
-e '/^CCFLAGS/s:=:+=:' \
-e 's/$(CCFLAGS)/$(CCFLAGS) $(LDFLAGS)/' \
-i Makefile || die
tc-export CC
export CCFLAGS="${CFLAGS}"
}
src_install() {
dobin tcping
dodoc README
}