You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/ttcp/ttcp-1.12-r2.ebuild

27 lines
622 B

# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
DESCRIPTION="Tool to test TCP and UDP throughput"
HOMEPAGE="
http://ftp.arl.mil/~mike/ttcp.html
http://www.netcore.fi/pekkas/linux/ipv6/
"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
SRC_URI="
mirror://gentoo/${P}.tar.bz2
https://dev.gentoo.org/~jer/${P}.c
"
src_compile() {
$(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} "${DISTDIR}"/${P}.c || die
}
src_install() {
dobin ${PN}
newman sgi-${PN}.1 ${PN}.1
}