You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/zmap/zmap-9999.ebuild

37 lines
695 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cmake fcaps git-r3
DESCRIPTION="Fast network scanner designed for Internet-wide network surveys"
HOMEPAGE="https://zmap.io/"
EGIT_REPO_URI="https://github.com/zmap/zmap.git"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="redis"
RDEPEND="
dev-libs/gmp:0
net-libs/libpcap
dev-libs/json-c:=
redis? ( dev-libs/hiredis )"
DEPEND="${RDEPEND}
dev-util/gengetopt
sys-devel/flex
dev-util/byacc
"
src_configure() {
local mycmakeargs=(
-DENABLE_DEVELOPMENT=OFF
-DWITH_WERROR=OFF
-DWITH_REDIS="$(usex redis)"
)
cmake_src_configure
}
FILECAPS=( cap_net_raw=ep usr/sbin/zmap )