You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-dns/mdns-repeater/mdns-repeater-1.11.ebuild

28 lines
550 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="Multicast DNS repeater"
HOMEPAGE="https://github.com/kennylevinsen/mdns-repeater"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm"
SRC_URI="https://github.com/kennylevinsen/mdns-repeater/archive/${PV}.tar.gz -> ${P}.tar.gz"
PATCHES=(
"${FILESDIR}/${P}-system-compiler-options.patch"
)
src_compile() {
emake HGVERSION="${PV}" CC=$(tc-getCC)
}
src_install() {
dobin "${PN}"
dodoc README.txt
}