You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/NativeThread/NativeThread-0_pre20190914....

32 lines
585 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit flag-o-matic java-pkg-2 toolchain-funcs
DESCRIPTION="NativeThread for priorities on linux for freenet"
HOMEPAGE="http://www.freenetproject.org/"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND=">=net-p2p/freenet-0.7
>=virtual/jdk-1.4"
RDEPEND=""
S="${WORKDIR}"
src_compile() {
append-flags -fPIC
tc-export CC
emake
}
src_install() {
dolib.so lib${PN}.so
dosym lib${PN}.so /usr/$(get_libdir)/libnative.so
}