You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/gssdp/gssdp-1.0.3.ebuild

58 lines
1.4 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
VALA_USE_DEPEND="vapigen"
inherit gnome2 multilib-minimal vala
DESCRIPTION="A GObject-based API for handling resource discovery and announcement over SSDP"
HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP"
LICENSE="LGPL-2"
SLOT="0/3"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~ppc ppc64 ~sparc x86"
IUSE="+introspection gtk"
RDEPEND="
>=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
>=net-libs/libsoup-2.44.2:2.4[${MULTILIB_USEDEP},introspection?]
gtk? ( >=x11-libs/gtk+-3.0:3 )
introspection? (
$(vala_depend)
>=dev-libs/gobject-introspection-1.36:= )
!<net-libs/gupnp-vala-0.10.3
"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.14
sys-devel/gettext
virtual/pkgconfig
"
src_prepare() {
# Disable functional test as it requires port that might be used by rygel to
# be free of use
sed 's/\(check_PROGRAMS.*\)test-functional$(EXEEXT)/\1/' \
-i "${S}"/tests/Makefile.in || die
use introspection && vala_src_prepare
gnome2_src_prepare
}
multilib_src_configure() {
ECONF_SOURCE=${S} \
gnome2_src_configure \
$(multilib_native_use_enable introspection) \
$(multilib_native_use_with gtk) \
--disable-static
if multilib_is_native_abi; then
# fix gtk-doc
ln -s "${S}"/doc/html doc/html || die
fi
}
multilib_src_install() {
gnome2_src_install
}