You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/iax/iax-0.2.2-r3.ebuild

33 lines
619 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools
DESCRIPTION="IAX (Inter Asterisk eXchange) Library"
HOMEPAGE="https://www.asterisk.org/"
SRC_URI="https://downloads.asterisk.org/pub/telephony/libiax/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
IUSE="debug snomhack"
PATCHES=(
"${FILESDIR}/${PV}-debug.patch"
"${FILESDIR}/${PV}-memset.patch"
"${FILESDIR}/${PV}-sandbox.patch"
)
src_prepare() {
default
eautoreconf
}
src_configure() {
econf \
$(use_enable debug extreme-debug) \
$(use_enable snomhack)
}