You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/kdav2/kdav2-0.3.0.ebuild

35 lines
708 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
ECM_TEST="forceoptional"
KFMIN=5.60.0
QTMIN=5.12.3
inherit ecm kde.org
DESCRIPTION="KJob based DAV protocol implementation"
SRC_URI="mirror://kde/unstable/${PN}/${PV}/src/${P}.tar.xz"
LICENSE="GPL-2+"
SLOT="5"
KEYWORDS="~amd64"
DEPEND="
>=kde-frameworks/kcoreaddons-${KFMIN}:5
>=dev-qt/qtgui-${QTMIN}:5
>=dev-qt/qtnetwork-${QTMIN}:5
>=dev-qt/qtxml-${QTMIN}:5
>=dev-qt/qtxmlpatterns-${QTMIN}:5
"
RDEPEND="${DEPEND}"
src_test() {
# disable tests requiring net access, bug #680952
local myctestargs=(
-E "(kdav2-davcollectionfetchjob|kdav2-davcollectioncreatejob)"
)
ecm_src_test
}