You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/libhtp/libhtp-0.5.37.ebuild

38 lines
856 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools multilib-minimal
DESCRIPTION="security-aware parser for the HTTP protocol and the related bits and pieces"
HOMEPAGE="https://github.com/OISF/libhtp"
SRC_URI="https://github.com/OISF/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
IUSE="debug static-libs"
RDEPEND="sys-libs/zlib[static-libs?]"
DEPEND="${RDEPEND}"
src_prepare() {
default
eautoreconf
}
multilib_src_configure() {
# The debug configure logic is broken.
ECONF_SOURCE=${S} \
econf \
$(usex debug '--enable-debug' '') \
$(use_enable static-libs static)
}
multilib_src_install_all() {
if ! use static-libs; then
find "${ED}" -name '*.la' -delete || die "Failed to remove .la files"
fi
}